Merc 4-cycle stalling, shutting off, misfiring at WOT. It was the TPS.

You know the drill..

Moderators: Redneck_Randy, badmoonrising, lakerunner

Post Reply
Message
Author
wrd1972
Posts: 236
Joined: Sun Jul 31, 2011 8:37 am

Merc 4-cycle stalling, shutting off, misfiring at WOT. It was the TPS.

#1 Post by wrd1972 » Mon Jun 05, 2023 11:26 am

Okay I have been chasing an super annoying issue on my Merc 90HP 4-cycle for years now, and I wanted to pass along the fix for me.

I saw the following symptoms:
-Randomly hard to start, cold or warm
-Randomly turning off when throttling down to neutral from WOT
-Random powerful and jarring misfires when at WOT

Its hard to diagnose things without the official Mercury scanner, and also when you dont have quick easy access to your boat. But all the pieces started to point to the position of the throttle lever, so I decide to take a chance and replace the throttle position sensor (TPS). So I have had two long days at the lake since replacing it, and there has not been the slightest single hiccup with the motor...Woohoo! I am feeling very good that this issue is now resolved. BTW, the TPS can be replaced in less than five minutes with a basic Torx driver and a can of beer.

Finally and for good luck, I gladly chucked that thing from the bow and sent it to the abyss of my local lake. Good riddance. LOL.

Keep on boating guys.
Bill
2008 Sun Tracker Party Barge 21' 2 Log NV performance Package, 90HP 4 stroke Mercury. 37MPH avg. on GPS.

User avatar
curtiscapk
Posts: 5404
Joined: Mon Nov 10, 2008 8:31 am
Location: OP KS\Hillsdale Lake

Re: Merc 4-cycle stalling, shutting off, misfiring at WOT. It was the TPS.

#2 Post by curtiscapk » Tue Jun 06, 2023 11:29 am

Nice to know good find!
Craig and Paula
"THE FLOATER" rebuild Spring 2013
viewtopic.php?f=2&t=15328
94 Party Barge 24' 115 merc
Turning Point hustler 14 x 13 prop
22mph gps 3 people
12 F150
Overland Park Ks
Hillsdale Lake, KS

User avatar
Reiner
Posts: 192
Joined: Tue Mar 25, 2014 11:46 pm
Location: San Diego

Re: Merc 4-cycle stalling, shutting off, misfiring at WOT. It was the TPS.

#3 Post by Reiner » Tue Jun 06, 2023 1:23 pm

Hello,
This maybe the problem I have on my 150 HP 4-stroke Mercury. Are you able to post a pic where the TPS is located?

Thanks Reiner
2015 Lowe SS 210 RFL XL Package 150 HP Merc
"The Nina" or "The Bismarck" my buddy's call it!
2011 Tundra

wrd1972
Posts: 236
Joined: Sun Jul 31, 2011 8:37 am

Re: Merc 4-cycle stalling, shutting off, misfiring at WOT. It was the TPS.

#4 Post by wrd1972 » Wed Jun 07, 2023 7:38 am

This is the best I could from on-line videos.

Again super easy to replace. Disconnect the sensor cables and remove two Torx screws. The old sensor will then pull off. You will see the metal throttle body shaft (where the TPS connects) will have a blade-like feature similar to a flat-tip screw driver. That feature needs to align with the plastic slot on the new TPS. Once its aligned and pressed onto the TB, simply rotate the TPS just a tad and bolt it on. Done.
Attachments
Untitled.png
Untitled.png (1.77 MiB) Viewed 12897 times
2008 Sun Tracker Party Barge 21' 2 Log NV performance Package, 90HP 4 stroke Mercury. 37MPH avg. on GPS.

User avatar
Reiner
Posts: 192
Joined: Tue Mar 25, 2014 11:46 pm
Location: San Diego

Re: Merc 4-cycle stalling, shutting off, misfiring at WOT. It was the TPS.

#5 Post by Reiner » Wed Jun 07, 2023 2:15 pm

Thank you, my 150 HP looks a bit different but that will give me an idea.
2015 Lowe SS 210 RFL XL Package 150 HP Merc
"The Nina" or "The Bismarck" my buddy's call it!
2011 Tundra

Post Reply